Rich-text Reply

Optimizely okhttp dependency problem

danigoldberg 11-10-15

Optimizely okhttp dependency problem

Hi, in the android documentation you recommend to add optimizely dependecies like this:

 

compile('com.optimizely:optimizely:+@aar') { transitive = true }

 

In our project we are using okhttp2.3.0 and if we use okhttp2.5.0 like you do we have some troubles with empty bodies.

 

do you have a solution for that? we can't use 2.5.0

 

Thanks,

Daniel

 

Joel_Balmer 11-11-15
 

Re: Optimizely okhttp dependency problem

Hi there @danigoldberg

 

Thanks for letting us know about this - we're looking into this for you now. I'll reach back out here once we have more information!

Re: Optimizely okhttp dependency problem

Hi, thanks for your reply. I will wait! Smiley Very Happy

 

Joel_Balmer 11-25-15
 

Re: Optimizely okhttp dependency problem

Hi again @danigoldberg, forgive the delay in my response!

 

Just to let you know that reverted back to okhttp 2.3.0 in our latest SDK version. To stay up to date with the latest SDK changes, please check out our changelogs, here.

 

I hope that helps!