Rich-text Reply

Can't enable my first optmizely test

GrogHills 12-15-14

Can't enable my first optmizely test

I'm trying to configure my first optimizeley test with no sucess. When I create the experiement for my home page, www.justahead.com, it says loading for a while, then reurns with the message "

Sorry, but we were unable to load http://www.justahead.com".

 

I've gone into the javascript console and issued the command optimizely and had an object returned, so it seems like the snipet is loading. Can someone have a look at my site and let me know if they have any thoughts? Thanks.

 

FYI...My snipet looks slightly different than the default. Details below...

 

For some reason the code on our site is different than the one they gave us. Maybe that's the problem. On our site it has a "type" and "?ver=1.0.03" parameters.

On our site...
<script type='text/javascript' src='//cdn.optimizely.com/js/2298470003.js?ver=1.0.03'></script>

From optimizely...

<script src="//cdn.optimizely.com/js/2298470003.js"></script> 

 

My developer's response is below...

 

WP adds type='text/javascript' for backwards compatibility for non-HTML5 sites & it shouldn't be a cause of Optimizely not getting data.

The "?ver=1.0.03" is the child theme version (which I add & update the version number after making a round of changes) to help flush browser caches which usually cache JS & CSS files.

http://cdn.optimizely.com/js/2298470003.js &
http://cdn.optimizely.com/js/2298470003.js?ver=1.0.03

renders the same code & browsers ignore after the ?, similar to when analytics code is appended to the URL.

 

Thanks in advance.

Aisha 12-15-14
 

Re: Can't enable my first optmizely test

Hi GrogHills,

It sounds like the main issue you're seeing is an inability to load your page in the Editor. Checking to make sure your snippet is on the page is a good first start, as our Editor uses the snippet to communicate with your site. I would also recommend enabling Mixed Content on your browser. Since your site uses an 'http' protocol, it's possible that we're unable to iFrame within our site, which uses a secure 'https' protocol. Enabling Mixed Content will allow you to bypass this restriction.

Here's a short how-to for doing this: https://help.optimizely.com/hc/en-us/articles/200179074-Pages-not-loading-in-the-Editor-troubleshoot...

Can you try this and see if that helps? Please follow up if you have other questions or insights.

Cheers,

Aisha
Customer Success and Technical Support @ Optimizely!
Optimizely