Rich-text Reply

Click Goal issue...

rburck 04-29-16
Accepted Solution

Click Goal issue...

 I have 3 variations plus the original.

 

  • Variations 1 and 2 are nothing more than an image swap to change color of the CTA.
  • Variation 3 edits html to simplify the CTA by removing surrounding content and supplying only the CTA.  
  • All variations are inside a <div id="contactUsBox">
  • The Click Goal is tracking the container #contactUsBox

 

In the Editor with "Highlight tracked elements in the editor (red outline)" checked, my click goals all show as being tracked. However. when I enter Preview mode, all variations trigger the Click Goal except variation 3.

 

I am 99.9% positive that when I QA'd this experiment prior to starting it, ALL variations triggered the Click Goal including variation 3. I am now concerned that users bucketed into variation 3 won't trigger the Click Goal.

 

As a test, I created a new project and duplicated this experiment into the new project so that I could edit it at will without messing up my current "running" exeriment... I then duplicated this particular webpage and renamed it.  I did nothing else so that except for using a duplicated version of the original webpage it is identical in every way. 

 

When I enter "Preview" mode in the TEST version, ALL variations trigger the Click Goal including variation 3...

 

Anyone have any ideas on what's going on?  Will variation 3 in my orginal experiment actually trigger the Click Goal? Why does it no longer trigger in preview mode?  User error? Anyone?

 

Bueller...? Bueller...? Bueller...?

 

Thanks!

 

R-

"Any plan no matter how poorly conceived, if boldly executed, is better than inaction."
~ Unknown ~
Level 2

DavidS 05-02-16
 

Re: Click Goal issue...

Hi rburck,

 

Thanks for reaching out!

 I have had a chance to log into your account and check that the goal was firing using the Force Variation parameter. I have been able to fire the goal on all three variations for both experiments in both projects on both pages. So it looks like the goal is indeed correctly set up and firing.  

 

It looks like this may be more an issue with Preview Mode than with goals themselves. I checked your results and while it is true that variation 3 is the only goal that has no conversion for this experiment, there is not enough data to make sure the goal is not indeed firing (all other variations only recorded one conversion). 

 

To check that goals are firing live on your website (outside of Preview Mode), we have a step-by-step tutorial on how to do so

 

Does that help clear things up?

 

Best,
David

 

Optimizely
rburck 05-16-16
 

Re: Click Goal issue...

David -

Thank you, yes that does clear it up. It's a bug in Preview Mode and not just me. Which is good news for me because it means it truly was not user error!

Thanks!

R-
"Any plan no matter how poorly conceived, if boldly executed, is better than inaction."
~ Unknown ~
Level 2