Rich-text Reply

Copy Test - Copy edits not taking

lewisgforman 07-24-15

Copy Test - Copy edits not taking

I'm working to change out some copy on one page (site is in Sitecore CMS) and the text isn't pasting when i try to replace a paragraph.  When it does take, the formatting is skewed and the page view test shows it in a completely different font. 

 

Anyone have these issues?

Re: Copy Test - Copy edits not taking

Hi @lewisgforman,

 

Without seeing your specific experiment this might be a bit tough to diagnose.  Are you using Edit Text or Edit HTML in our Visual Editor?  If you are using Edit Text, we are actually applying that text's style(s) behind the scenes.  If you copy and paste text in that box that had style or formatting in the original source, you'd be applying it in that box, and that might not play nice with the style on your site.  I'd recommend pasting your copy into a simple text editor before pasting it into the Visual Editor to ensure all source formatting has been removed.

 

If you are using Edit HTML, this function essentially does a blind wipe of all the code for that element and replaces it with whatever code you provide in the box.  For smaller or more specific elements like text or links this can be OK but larger elements with lots of child elements this could have unintended side effects, e.g. removing or changing styles.

 

Does either of these situations apply to you?  Could you provide your experiment ID where this is happening?

 

Thanks.

Harrison Krat
Solutions Architect | Optimizely, Inc.
harrison@optimizely.com
 

Re: Copy Test - Copy edits not taking

[ Edited ]

@Harrison_Krat -

 

I'm using Edit Text.  The original alternate text being used in our experiment was in a Google Doc.  I tried Notepad (I'm on a MAC), Word, email box to copy/paste into the editor.  Everytime there's weird shifts and text won't hold the font (proximo regular).

 

Experiment ID is:  3203551096

 

I'm doing a similar thing to two other tests where we are also seeing the same results in output of the test page with the new text.  I've attached the new text being used in a Word doc if that helps.

 

Any help or thoughts would be greatly appreciated!

 

Lewis

Re: Copy Test - Copy edits not taking

[ Edited ]

Hi @lewisgforman,

 

Thanks for sending those details over.  When I look at your experiment variation, and I preview the variation, everything looks perfect to me.

 

I think the best approach is do a deeper 1:1 dive on this issue with a member of our Support team.  Could you please file a case here and provide a screenshot of the bad formatting you are seeing?

 

Thanks.

Harrison Krat
Solutions Architect | Optimizely, Inc.
harrison@optimizely.com