Rich-text Reply

Error after starting test, only effects homepage

DarrellF 02-09-15

Error after starting test, only effects homepage

I've just started a test which looked fine during editing and testing but now the test has been started there is a bug with an element being displayed twice.

 

I'm running a test which rearrages the elements on the header sitewide. In the original the elements should run; logo, search input and basket, from left to right, and in the test the logo and search input should be swapped round. After some tinkering I was able to get the elements arranged correctly in the editor and then previewed the site before going live.

 

However, once the test was run and I checked the test on the site, the basket now appears twice. I've checked the testing code and can't see any problems with it, the rearranging was done with detach() and insertAfter() and the elements which need to come before the insertAfter() are inplace before that function call, if that makes sense.

 

But the oddest part is that this problem only occurs on the homepage. The URL targetting is set to the root (homepage) on substring match, could this be effecting it? Has anyone else had any similar problems?

 

Regards.

Level 2

JDahlinANF 02-09-15
 

Re: Error after starting test, only effects homepage

Perhaps the basket item you are detaching actually exists on the page twice?

greg 02-09-15
 

Re: Error after starting test, only effects homepage

Can you share the variation code and the affected site? It would help with troubleshooting. Some times jQuery and CSS behave in unexpected ways, so the issue might be in the code.

Level 2