Rich-text Reply

Filter doesn't work when anonymize is on

Volkan 01-26-15

Filter doesn't work when anonymize is on

I have been testing to see if IP filtering is working and the only time I could get it work is if I turned IP anonymize off and put the full IP in without any regex. 

 

If I select IP Anonymize it says:

"If you also anonymize IP addresses, your regular expression should also match IP addresses without their last octet."

 

Thus I have tried the following regex:

^14\.202\.143.*$

 

This doesn't seem to work.

 

I need regex, for multiple IPs, and I need IP anonymize on. 

 

Any suggestions?

Level 2

MartijnSch 01-27-15
 

Re: Filter doesn't work when anonymize is on

Hi Volkan, how did you found out it's not working? The IP filters are not applicable to you seeing the test but just your results won't be accounted for as they're excluded on IP basis.
Volkan 01-27-15
 

Re: Filter doesn't work when anonymize is on

I open the order confirmation page on our website and refreshed at 5 minute intervals to see if the revenue from my order was tracked.

I did this under various filter setting using my ip/regex/ip anonymize as outlined above.

The revenue always tracked (even though it shouldn't) except when I used my full IP, no regex, and IP anonymize off.
Level 2
Joel_Balmer 02-03-15
 

Re: Filter doesn't work when anonymize is on

Hi there!

 

Optimizely anonymizes IPs by removing the last octet, so you should be able to filter out the IP:

 

14.202.143.

Using

 

^(14\.202\.143\.)$

Or

 

^14\.202\.143\.$

I hope that helps!

 

Kind regards,

 

Joel

 

Volkan 02-04-15
 

Re: Filter doesn't work when anonymize is on

Thanks Joel.

I had tried ^14\.202\.143.*$ and ^14\.202\.143.$.

I tried with the braces and it seems to be working. I will do further testing tomorrow.
Level 2