Rich-text Reply

Force parameter is not working!

ydoll 02-08-16
Accepted Solution

Force parameter is not working!

I am in an incognito window, the url is http://www.mauijim.com/?optmizely_x4923651804=1 but it's still showing the original version. I cannot get the variation to load. Any ideas? 

I already checked to make sure the force parameter is not disabled in the settings.

 

Yvonne

Level 2

Joel_Balmer 02-08-16
 

Re: Force parameter is not working!

Hi Yvonne,

 

Looks like you're using force query parameter, here. I just tried your URL which loads fine, but when I check the Optimizely object using the browser's console (see Optimizely's article on this, here), it shows that you have no activeExperiments. Then, insteead of checking activeExperiments I checked:

 

optimizely.allExperiments

 

This showed me you have 2 experiments in your project, 3444370380 and 3524080847. Neither of these experiment IDs match the experiment you've provided in your URL. So it looks like this experiment isn't part of the project. 

 

Here are some things to check:

 

  1. The snippet on your page is http://cdn.optimizely.com/js/3471290170.js, so check your experiment is in this project (id 3471290170) and not another. If it's in another, move it to this project, or change the snippet on your page
  2. Check whether your project hasn't been excluding draft experiments, or simliar privacy settings that mean the snippet can't access the experiment at the moment, here.

 

I hope that helps you get to the bottom of this!

ydoll 02-08-16
 

Re: Force parameter is not working!

Awesome, that worked. I didnt realize the projects were linked to a specific install script. Thanks so much for the speedy reply!
Level 2
dboroi1 Tuesday
 

Re: Force parameter is not working!

I'm having the same issue. 

 

http://www.jegs.com/c/Fuel-Carbs-Intakes/10267/10002/-19393061518?optimizely_x=9263135103&optimizely...

 

Continues to show the original. I see the variation fine in the editor preview. I'm using Incognito. This is first test trying to run on Optimizely X. Privacy settings should be ok. 

Level 2