Rich-text Reply

Getting code 500 error after integration crazyegg

Tomas 01-04-15

Getting code 500 error after integration crazyegg

I’ve been trying Optimizely a few days, all working fine. Today I added integration wih Crazyegg and can’t create new experiments or integrate with previously made experiments.

 

Problem occurs when loading the snapshot. It does load but a pop up says:

 

Something went wrong.

CrazyEgg: Create snapshot failed with status code 500

If this error persists, please let us know at our support page.

Our engineering team has been notified.

1c4eac9b-f6e5-43e2-8585-608381aa1f9f | 2015-01-04T17:26:50Z

 

I have double checked these to things:

 

  • Make sure to install the CrazyEgg code snippet on your site below the Optimizely Snippet for this integration to work.
  • Additionally, make sure that your Settings (in the Home page > Settings tab) are set so that the Force Variation box is unchecked.

 

Anybody having any idea to what else I can do?

 

Thanks

Level 2

Brian_Abad 01-05-15
 

Re: Getting code 500 error after integration crazyegg

Hey @Tomas ,

 

Does this error occur when creating an Optimizely experiment? There is a related bug that is currently filed for our Engineering team to take a look into but I'd like to confirm that this is the same thing. If the error occurs within the edit experiment page it may be related.

 

Thanks for confirming this for me!

---
Brian Abad
Manager, Technical Support
Customer Success
Optimizely
Tomas 01-06-15
 

Re: Getting code 500 error after integration crazyegg

Hi Brian,

 

It occurs first when a new experiment is created. The snapshot does load, but then the error messages pops up and also the green btn in top right corner says “error” instead of “start experiment”. After that I can make changes to the page but not save them as “save now” button never activates.

 

However, if I go back to the experiments overview and select the same experiment, the same thing will happen, it loads, and then the error but now I can edit and save the page and the green btn in top right corner says “start experiment”.

 

After some trial and error on how to go back and forth I‘ve managed to get an experiment started after integration with crazyegg. But it’s much more complicated and time consuming.

 

Logging in to crazyeggs I see no new Optimizely snapshot. Maybe it takes some time before it appears? I'll give it a few hours and check again.

 

Thanks.

Level 2
Brian_Abad 01-06-15
 

Re: Getting code 500 error after integration crazyegg

Hey @Tomas ,

 

Thanks for the additional information!

 

This sounds like the same bug that is currently filed so I'll be sure to follow-up with you once I hear a response from our Engineering segment looking into it. Please keep us posted on whether the snapshots are generated. The steps you've mentioned in your inital post **bleep** generating. 

 

Thanks for your help in identifying this error!

---
Brian Abad
Manager, Technical Support
Customer Success
Optimizely
Tomas 01-12-15
 

Re: Getting code 500 error after integration crazyegg

It’s been a few days, no snapshot in crazyegg showing.


I’ll just wait for the bug you are currently sorting out to be sorted and hope it will help!

 

Thanks.

Level 2
michaelwei 01-12-15
 

Re: Getting code 500 error after integration crazyegg

Hi Tomas,

 

The bug from before is now fixed! Open the experiment(s) that you want to add CrazyEgg tracking for, and double check to make sure the CrazyEgg integration is checked under Options -> Integrations. Once checked and saved, you should start to see data showing up in the CrazyEgg Dashboard within 24 hours!

Optimizely
Tomas 01-13-15
 

Re: Getting code 500 error after integration crazyegg

Yes indeed, seems it was related.
I activated the integration and it was immediately registered as a snapshot in crazyegg.


It will be interesting to see the results from the experiment with crazyegg snapshots and Universal Analytics too.

 

Thanks!

Level 2