Rich-text Reply

Google Analytics Custom Dimensions Sporadically Not Working

mrcthms 03-03-16

Google Analytics Custom Dimensions Sporadically Not Working

Hey there,

 

I'm experiencing some odd behaviour with one of our active experiments. We're using the Google Analytics custom dimension integration so we can eaisly segment the results in GA as well as the results panel in Optimizely.

 

Now, by going to an experiment page, and running it with ?optimizely_log=true appended, I can see that sometimes the ga('set', 'dimension8', 'value'); doesn't get called, and sometimes it does. I've tested this on the exactly same URL, after clearing cookies each time and it seems to either get called, or not, with no clean indication of settings that trigger this.

 

I've got both the Optimizely logging, and the Google Analytics event logging extension for Chrome running to debug what's being called.

 

I've attached screenshots of the events when it fires, and when it doesn't.

 

Do you know of any reason why sometimes the ga call would not be made? It's causing inconsistencies in our Google Analytics data, rendering it pretty much unusable at the moment which is a concern.

 

Working:

 

Screenshot 2016-03-03 18.02.37.png

 

Not working:

 

Screenshot 2016-03-03 18.05.52.png

 

Any help would be greatly appreciated!

 

Thanks,

Marc

Level 2

Re: Google Analytics Custom Dimensions Sporadically Not Working

Hi mrcthms,

Thanks for posting your question! I'd like to take this discussion away from Optiverse and into an email conversation. Can you pm me an email address I can reach you at?

Best,
Nils
mrcthms 03-07-16
 

Re: Google Analytics Custom Dimensions Sporadically Not Working

Hey Nils,

Sure thing, let's talk about this later on!

Marc
Level 2