Rich-text Reply

Google Analytics integration missing parts of data

onetouch 07-12-16
Accepted Solution

Google Analytics integration missing parts of data

Hello,

 

I have been using Optimizely for a few months and I have never had problems integrating Google Analytics. Since my last test (which is still running), I have noticed that my custom report based on the custom dimension that I have set in optimizely is only showing 3% of all my sessions. 

 

My settings for the traffic allocation is 100% (50% original - 50% variation). In Google analytics it states 60% - 40%. 

 

I have tried restarting the test, new custom dimension, but with no luck.

Any ideas or suggestions would be appreciated.

 

Thank you in advance.

 

Diego

Level 1

DavidS 07-13-16
 

Re: Google Analytics integration missing parts of data

Hi onetouch,

 

Thanks for reaching out to Optimizely!

Have you checked out this article? It contains a lot of information on how to debug the Optimizely/Google Analytics integration. 

 

You'll also want to make sure the Google Analytics Custom Dimension is being set in between the Google Analytics ga('create') and ga('send') trackers. 

 In your Google Analytics Custom Report, I recommend you also check your filter to make sure that you are filtering the correct experiment ID. 

 

Best,
David

 

Optimizely
onetouch 07-26-16
 

Re: Google Analytics integration missing parts of data

Hi David,

 

Thanks for reaching out. 

The custom dimension is set correctly.

 

I have now checked the article.

The solution would probably be placing the optimizely snippet above the GA snippet. The optimizely snippet is now on the bottom of the page together with the other javascript files.

 

Kind Regards,

Diego

 

 

 

Level 1