Rich-text Reply

Optimizely + Cache = Not Working

SMoKeR 11-01-15

Optimizely + Cache = Not Working

Hello everyone,

I'm having a problem with a test I'm running.

Initially when I tried to load my site into the editor I wasn't able to do so. It's only after turning off the cache that my site finaly loaded and I was able to create the test.

 

I've let the test run 2 days and then I turned on the cache on my site, from that point on the test stopped tracking and I'm no longer receving data in optimizely.

 

How do I fix this problem?

 

I'm using wordpress 4.3 and W3 Total Cache plugin.

Level 2

SMoKeR 11-01-15
 

Re: Optimizely + Cache = Not Working

btw, I'm still seeing the optimizely snippet when viewing the source code, so I think it's something to do with the caching settings...
Level 2
MartijnSch 11-02-15
 

Re: Optimizely + Cache = Not Working

Are you caching all the JS files through your caching plugin? This could be why the new versions of your Optimizely code aren't working properly.
SMoKeR 11-02-15
 

Re: Optimizely + Cache = Not Working

I think the problem was solved, all of a sudden the data popped up in my optimiezely dashboard.

How come it took a few days for the data to refresh?

Level 2

Re: Optimizely + Cache = Not Working

Hey Smoker! To build off what Martijnsch said I believe this has to do with your cache settings. I know that W3 Total Cache can be setup to heavily cache files on your site. I would recommend either not caching the optimizely snippet or limiting it to only one minute. This way you always have the latest snippet on the site.
Optimizely