Rich-text Reply

Optimizely Drupal Integration

TeamFYZ 02-02-15
Accepted Solution

Optimizely Drupal Integration

Hi,

 

 

I did exactly what I have to do in order to integrate optimizely and I wonder why it doesn't work.

 

The source code of my drupal site shows that the snippet is there (I added via the Optimizely module for drupal) and my firefox plugin shows me that Google Analytics and Optimizely are running effectively on my website.

 

But when I create an experiment on the dashboard of opimizely it doesn't load my website.

Is it a matter of time before working or something wrong I did you can check my screenshots.

 

Thank you for your time and for your help (if you need additionnal information I'm here)

 

The first pictures shows my main problem is it normal that my drupal website can't be load on Optimizely ?

 

screenshot3.png

 

 

screenshot2.png

 

screenshot1.png

Level 2

Brian_Abad 02-03-15
 

Re: Optimizely Drupal Integration

Thanks for the screenshot! Extremely helpful in diagnosing what's going on.

The Optimizely snippet is correctly installed on the page -- the next step you'll want to take is enabling mixed content within the Optimizely editor. That process is outlined in full within our knowledge base: https://help.optimizely.com/hc/en-us/articles/200179074-Pages-not-loading-in-the-Editor-troubleshoot...

Please let me know if I can help with anything else!
---
Brian Abad
Manager, Technical Support
Customer Success
Optimizely
TeamFYZ 02-04-15
 

Re: Optimizely Drupal Integration

Thank you for your message Brian! I tried what you told me to do but it doesn't work. I have a question the ID of my drupal project has to be the same as the ID of the Optimizely Experiment ?

 

Here's two screenshot :

 

You can see that I circled the ID and this ID has to be the same as the experiment ID right ?

 

Thank you for your help!

 

screenshot5.pngscreenshot4.png

Level 2
Brian_Abad 02-04-15
 

Re: Optimizely Drupal Integration

Thanks for the reply!

 

I checked your webpage and it looks like the wrong Optimizely snippet is currently installed. To find your Optimizely snippet go to the Optimizely Dashboard (http://optimizely.com/dashboard) and select Settings. You'll find the code present there which is what you'll want to install by the opening head tag of your site.

 

Once you've done this, on your webpage, go back to the Optimizely Dashboard and select Overview within the same project in which you retrieved the snippet. This is where you'll want to create an experiment. 

  • In general, the Optimizely snippet installed on a webpage is associated with a specific Optimizely Project. The numbers at the end of the snippet are the same as the Project ID in which you'll want to create the associated experiments. 

Once you have the correct snippet installed, create a new experiment within the associated project, enable mixed content, and your site should load correctly.

 

Please let me know if any of this is unclear!

---
Brian Abad
Manager, Technical Support
Customer Success
Optimizely
TeamFYZ 02-04-15
 

Re: Optimizely Drupal Integration

I'm sorry but it still doesn't work I did word for word what you told me but it seems that there may be other issues.

 

1/ I created a new project on Optimizely

2/ I took it's ID in Settings and I created a new Project in my Drupal Dashboard with the same ID (this time my website's ID is the same as the project ID)

3/ I created an experiment (and enabled mixed content)

 

But I got nothing, the diagnostic report is telling me that my experiment's targeting url settings don't match.

 

Took many screenshots to be as clear as possible if you need more information I'm here.

 

Did I something wrong ?

 

Thank you for your time!

 

 

 

 

screenshot6.pngscreenshot7.pngscreenshot8.pngscreenshot9.pngscreenshot10.png

Level 2
Brian_Abad 02-04-15
 

Re: Optimizely Drupal Integration

Thanks for the detailed screenshots. I can confirm that the correct snippet is on the page. I am able to load your experiment on my end within my Chrome browser.

Could you try using Chrome and enabling mixed content for your experiment?

Additionally, when loading the visual editor another method to help could be to append the following query parameter: `optimizely_disable_proxy=true`. This would look like: https://www.optimizely.com/edit?experiment_id=1234567&optimizely_disable_proxy=true.

On my end everything is checking out so I'd like to see how Chrome and replicating the steps I've mentioned above works for you.

Thanks!
---
Brian Abad
Manager, Technical Support
Customer Success
Optimizely
TeamFYZ 02-05-15
 

Re: Optimizely Drupal Integration

Thanks a lot Brian amazing customer service congrats!

Level 2