Rich-text Reply

Optimizely and Marketo

lilyt 07-03-14

Optimizely and Marketo

[ Edited ]

Hi,

 

I am having trouble implementing Optimizely in some of my Marketo landing pages. I already followed the directions that was provided my Optimizely getting started: https://help.optimizely.com/hc/en-us/articles/200040505

 

But I am still having trouble getting my tests to run.  

Has anyone had issues with this?  If so please advise.

 

Thanks,

Lily

Level 2

adzeds 07-04-14
 

Re: Optimizely and Marekto

Lily,

What exactly is the issue? Can you see the Optimizely code on the page?

Is the issue with getting the code onto the page or getting your tests to appear?

David
David Shaw
Level 11
Amanda 07-08-14
 

Re: Optimizely and Marketo

@lilyt  - we would be happy to help. As @adzeds mentioned, can you provide a bit more detail on where you're seeing the issue? Also, if you can point us to a URL where you expect a test to be running that would also be helpful. 

 

To confirm whether the snippet is on the page, you can type optimizely into the console. You should see an object returned if optimizely is definted. See attached for an example of where it has not been implented correctly.  

 

With Marketo, you'll need to ensure that you are not saving over the templates where the snippet was implented. 

 

Screen Shot 2014-07-08 at 2.44.15 PM.png

Optimizely
lilyt 07-11-14
 

Re: Optimizely and Marketo

Hi @adzeds and @amanda,

A little background, I inserted the Optimizely code into my Marketo landing page's template. But when I go on my page on the internet browser I do not see the snippet therefore not running the A/B tests. (I use Ghostery to track all the beacons/ads/etc).

The problem is getting the test to appear, I have successfully put the code into Marketo, but the tests are not running.

This is the landing page the snippet should be running on: http://mlps.siliconexpert.com/cross-reference_lp.html

Any help would be appreciated, thanks so much,
Lily

Level 2
Amanda 07-15-14
 

Re: Optimizely and Marketo

I am going to do some research on this to see if I can find additional information on what might be going wrong. Can you confirm that your changes to the page have been actually pushed to production? I am not really familiar with Marketo, but I'll try asking their team what some common culprits might be. 

Optimizely
Amanda 07-15-14
 

Re: Optimizely and Marketo

Hi @lilyt , Here is a tip that I got from the Marketo community on why the snippet may not be properly added to your landing page. The location seems to be a common cause for an issue such as the one you are describing. 

 

"Moving the snippet to the header could be an option, using Design Studio - Landing Page Actions - Edit Page Meta Tags - Custom HEAD HTML." 

 

If this doesn't work, can you provide some details and a screenshot of the steps you took to add the snippet? 

Optimizely