Rich-text Reply

Optimizely editor won't load pages, with + in the URL

plac3bodk 03-03-16

Optimizely editor won't load pages, with + in the URL

Hi everyone.

 

As the header implies, I'm having some issues with loading up pages, in the editor, that has + in the URL.

 

Is there anyway to escape these special characters in the editor settings`?

 

Thank in advance

 Henrik

 

 

DavidS 03-04-16
 

Re: Optimizely editor won't load pages, with + in the URL

Hi plac3bodk,

 

Thanks for reaching out!

 

As far as I know, there are no known issues with a + in the url. Pages should load fine in the Visual Editor. Are you experiencing the same issue when you remove the query parameters that have the "+" sign?

 

If so, this could be a browser issue rather a URL issue. Here are some steps to ensure that the page has the best chance of loading into the editor using Google Chrome:

1. Enable Mixed Content to allow unsecured pages to load into the Editor.
2. Install the Optimizely Chrome Extension to allow pages that refuse to load in iframes to load into the Editor's iframe.
3. Install the Optimizely snippet

 

If this is doesn't work, could you try loading the page using Mozilla Firefox? Also, please keep in mind that you will need to enable mixed content in Firefox to allow the page to load in the Visual Editor.

 

If you're still having issues with the Visual Editor, would you mind posting a link to your website so i can have a look? If you don't want to share the URL publicly, you can pm me directly the link.


Best,
David

Optimizely
kkhvi 03-04-16
 

Re: Optimizely editor won't load pages, with + in the URL

Hi David

Thanks for replying.

I've already tried enabling Mixed content and the Optimizely snippet is implemented.

I just tried installing the Optimizely extension for Chrome, so I'll have a go with that later on today.

I'll let you know what I end up with Smiley Happy

Kind regards

 Henrik

Level 2