Rich-text Reply

Optimizely is ignoring Audience: Query parameters

mkstvnsn 12-14-16
Accepted Solution

Optimizely is ignoring Audience: Query parameters

[ Edited ]

Hey guys, Im in a bit of a bind. Optimizely is flat out ignoring my audience query parameter setting. I have my audience set to require a parameter of "financial_ins", but the experiment triggers even when the query parameter is NOT in the url. 

 

Here's the parameter:

 

Screen Shot 2016-12-13 at 6.44.36 PM.png

 

I'm testing this by adding a sessionStorage, that Optimizely is adding even when there is NO query parameter in the URL

 

sessionStorage["financial"] = 'yes';

What am I doing wrong?

 

ALSO

 

I just tried a different approach, to target the url instead of the query parameter. So I set my URL targeting to only include "financial_ins", but I STILL have the problem. Optimizely is ignoring this, too. So when I go to my www.website.com without the parameter, the experiment still runs. This is my experiment ID if anyone from Optimizely reads this

 

8024240681

Level 2

RyanC 12-14-16
 

Re: Optimizely is ignoring Audience: Query parameters

I would go ahead and use "URL Targeting" and include "financial_ins" as a substring requirement. However in your case it seems like there is something weird going on .... I would try to duplicate the experiment and see if that solves the problem.
Ryan
------------------------------------------------
The best solution is the simplest.
Experimentation Hero
mkstvnsn 12-21-16
 

Re: Optimizely is ignoring Audience: Query parameters

Hey Ryan, thanks for responding. I ended up just creating a new experiment with the exact same structure and it worked. Not sure what was wrong with the old one
Level 2