Rich-text Reply

Original page not loading in preview mode

mfanning 10-19-15

Original page not loading in preview mode

Hi.

 

When in preview mode, the original page in my AB experiment does not load (clickback.com).

 

See video: http://screencast.com/t/rtzZe5IQy0G

 

We've put the Optimizely code snippet in the <head> tag of the index.asp file right after an include "_head.asp" file as putting it above the include seemed to affect page load performance.

 

See below:

 

<html lang="en">
<head>

<title>B2B Lead Generation Software | Clickback</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="keywords" content="lead generation software, b2b lead generation, clickback">
<meta name="description" content="Clickback's lead generation software helps B2B companies turn cold contacts into warm leads. Call 1.866.684.4932 to request a free demo.">
<meta name="author" content="Clickback, 2015">
<!--#include virtual="/_head.asp"-->
<script src="//cdn.optimizely.com/js/3710882646.js"></script>

</head>

 

I've also provided the _head.asp #include file below for reference. We also tried putting it at the top of this include file but still encountered the same "blank screen" problem.

 

<!--#include file="GetRep.asp"-->
	<!-- Import Google Fonts -->
<link href='http://fonts.googleapis.com/css?family=Open+Sans:400italic,600italic,700italic,400,600,700' rel='stylesheet' type='text/css'>
		<link rel="stylesheet" type="text/css" href="/styles/screen.css" media="screen">
		<link rel="stylesheet" type="text/css" href="/styles/mobile.css" media="screen">


		<link rel="stylesheet" type="text/css" href="/styles/jquery.placeholder.min.css" media="screen">
		<link rel="stylesheet" type="text/css" href="/styles/print.css" media="print">
		<link rel="stylesheet" type="text/css" href="/styles/responsiveslides.css">
<meta name="viewport" content="width=device-width, user-scalable=no" />
		<!--[if lt IE 8]>
			<link rel="stylesheet" type="text/css" href="/styles/screen-ie7.css" media="screen">
		<![endif]-->

		<!--[if IE 8]>
			<link rel="stylesheet" type="text/css" href="/styles/screen-ie8.css" media="screen">
		<![endif]-->


		<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js" type="text/javascript"></script>
		<script src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.18/jquery-ui.min.js" type="text/javascript"></script>



		<script src="/scripts/jquery.selectric.min.js" type="text/javascript"></script>
		<script src="/scripts/jquery.placeholder.min.js" type="text/javascript"></script>
		<script src="/scripts/general.js" type="text/javascript"></script>
		<script src="/scripts/responsiveslides.min.js"></script>
   		<script src="/scripts/jquery.mmenu.min.all.js" type="text/javascript"></script>
   		<link href="/scripts/jquery.mmenu.all.css" type="text/css" rel="stylesheet" />
		<script>
			$(function() { $(".rslides").responsiveSlides({
				auto: true,
				pager: true,
				speed: 2000,
				timeout: 10000,
				namespace: "centered-btns"
			});});
		</script>

		<script type="text/javascript">
           $(document).ready(function() {
              $("#menuBar").mmenu({
                 // options
              }, {
				 clone: true,
                 // configuration
                 offCanvas: {
					position: "right",
					zposition: "front",
					moveBackground: "true",
					title: "Clickback",
                 },

			   });

			    $("#mm-menuBar").mmenu({"header": {
					 "title": "Title",
				}});

			   $("#mm-menuBar").mmenu()
         			.on( "opening.mm", function() {
			            $("#headerContainer").css("display", "none");
			            $("#cta").css("display", "none");
			         })
				$("#mm-menuBar").mmenu()
         			.on( "closed.mm", function() {
			            $("#headerContainer").css("display", "block");
			            if ($("#mobile-header").css("display") == "block")
							$("#cta").css("display", "block");
			         })

           });
        </script>



<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-3859022-1']);
	_gaq.push(['_setDomainName', 'clickback.com']);
	_gaq.push(['_setAllowLinker', true]);
	_gaq.push(['_trackPageview']);
	setTimeout("_gaq.push(['_trackEvent','15_seconds', 'read'])",15000);
	(function() {
		var ga = document.createElement('script')
		ga.type = 'text/javascript';
		ga.async = true;
		ga.src=('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script>

Thanks.

 

Mitch

Level 1

JDahlinANF 10-19-15
 

Re: Original page not loading in preview mode

[ Edited ]

{ edit }

Disregard - I mis-read the question.

Lyndsey 10-29-15
 

Re: Original page not loading in preview mode

Hi Mitch!

Thank you for reaching out to the Optimizely support team!

I see that you have also logged a ticket, so I've responded to you fully there - however just to debrief, adding the query parameters used to load the page through Optimizely preview has resulted in the entire body of the page being removed (thus, loading blank). Some developers will restrict this to reduce the possibility of viruses being passed on to pages. Do you have a developer or web admin who can check your page to see if certain query parameters are blocked? In the meantime I've verified that you can load both variations using force variation parameters (https://help.optimizely.com/hc/en-us/articles/200107480-Force-a-specific-variation-to-run-and-other-... and sent over the direct links you can use to view both renderings.

I hope that helps, feel free to respond back to the ticket if you have any further questions!
Thanks,
Lyndsey
Technical Support Engineer
Optimizely
Optimizely