Rich-text Reply

Results not registering although code snippet is installed according to instructions

tnosugar 11-24-14
Accepted Solution

Results not registering although code snippet is installed according to instructions

Hello,

 

I would need some help. I believe we have correctly installed the Optimizely snippet, but for some reason it has registered only one visit on one of the variants and stopped.

 

Notice: I have visual website optimizer code installed on the same web site, but this should not be an issue.

 

The code is installed on the following web site: www.balkaninsight.com

 

I also noticed that the same snippet is activated twice in the log (see image below).

 

Can anyone help?

 

 

Level 2

Brian_Abad 11-24-14
 

Re: Results not registering although code snippet is installed according to instructions

Thanks for reaching out to us with your question!

 

There are a few things I'd check to see if you've gotten your experiment up and running correctly:

 

  1. Do your Audience visitor conditions unintentionally exclude anybody?
  2. Does the URL Targeting correctly encompass the landing page(s) users access? Feel free to access your webpage and compare that URL with the URL Match Validator tool available within the Optimizely editor! (https://help.optimizely.com/hc/en-us/articles/200040835#match_validator)
  3. Is your Traffic Allocation appropriately set? Ensure it isn't at a very low level where only a small percentage of your traffic would be included within this experiment.
  4. Does IP Filtering at the project-level exclude any visitors from being counted within the Results page?

 

Additionally, while Preview Mode is a great tool, we do have some other suggested practices to check whether your experiment is running correctly before setting it to live visitors. You can see that complete list within our knowledge base article: https://help.optimizely.com/hc/en-us/articles/201862554-Your-Pre-Launch-Checklist-QA-your-experiment...

 

Could you check these settings and let us know how that works? Thanks and feel free to reach back with additional questions!

---
Brian Abad
Manager, Technical Support
Customer Success
Optimizely
Amanda 11-25-14
 

Re: Results not registering although code snippet is installed according to instructions

[ Edited ]

@tnosugar - is it possible that you are adding the snippet via a tag manager or similar tool ? I only see the code once in the page source, but I see the snippet loaded 2x in the network events.  This seems to suggest that the other, duplicate, snippet is being loaded through a third party system. See the attached network events for reference (you already actually found this when mentioning your preview code)

 

The fact that your snippet is being added to the page twice  is very problematic, but should not prevent your results from showing up. [You should still remove the duplicate snippet to prevent one from overwriting the other]

 

Perhaps the real reason why you are not getting any traffic is because your targeting is set to http://www.balkaninsight.com, but when I visit that page, I am immediately redirected to http://www.balkaninsight.com/en/page/all-balkans-home. Check out #2 in @Brian_Abad's post for tips on how to confirm your URL targeting is right. 


If you can make your URL targeting match the page a visitor will actually land on, then you should be just fine! 

 

Let us know if you have any questions on this. 

 

Screen Shot 2014-11-24 at 5.16.12 PM.png

Optimizely
tnosugar 11-25-14
 

Re: Results not registering although code snippet is installed according to instructions

It was #2. Thanks a mil for the very quick reply. A great community as advertised.

@Amanda Since I'm a newbie obviously, could you tell me where I can see whether the snippet is loaded once or twice. I came upon that view by chance. Thank you both Smiley Happy
Level 2
Amanda 11-25-14
 

Re: Results not registering although code snippet is installed according to instructions

Looks like just once now. Did you remove one or did something change? 

 

Also looks like your experiment is running as expected now on http://www.balkaninsight.com/en/page/all-balkans-home Smiley Happy

Optimizely
tnosugar 11-25-14
 

Re: Results not registering although code snippet is installed according to instructions

Yes. Perhaps it was triggered twice because I did not check the redirect option from www.balkaninsight.com to www.balkaninsight.com/en/page/all-balkans-home. There is a 301 redirect on the root domain, however, so I'm not sure why it would register the snippet in that instance.
Level 2
Amanda 11-25-14
 

Re: Results not registering although code snippet is installed according to instructions

That could be it. In any case, you seem to be all set now. Let us know if anything else comes up or if we can help in any other way. 

Optimizely