Rich-text Reply

Stuck in Compatibility Mode, can't get past Login

BenHB 02-19-16

Stuck in Compatibility Mode, can't get past Login

[ Edited ]

Hi all,

 

First-time poster here and new Optimizely user. I'm trying to add my first experiment which happens to be on a gated feature.

 

The editor redirects me to our app's login page and throws a Compatibility warning.

 

What's weird is from here I can switch to Interactive mode and create an account on our site, but if I try to log-in, nothing happens and I receive no console errors. I figure something is being disabled?

 

Here's what I've tried:

 

  • logged into our website in one tab
  • fired up the Optimizely editor in another tab
  • get redirected to the login
  • double-checked the URL into the editor settings (https://app.appname.com/specific_path)
  • tried in both Chrome and Firefox with Compatibility Mode disabled
  • tried logging in using Interactive mode (nothing happens)
  • tried using both https and http for the url, as well as just the url without the http prefix (app.appname.com)

Worth noting:

  • I've checked that the script is availabe on our live app (it's shown as a script in the head tag, and typing 'optimizely' into the Chrome Console works.
  • I'm seeing the error in the console below. Not sure why it thinks our app is http and not https

Screen Shot 2016-02-18 at 4.54.20 PM.png

 

Thanks for any guidance!

Level 1

DavidS 02-22-16
 

Re: Stuck in Compatibility Mode, can't get past Login

Hi BenHB,

 

It sounds like you are having issues with logging into your site from within the Visual Editor. This might be happening due to the way the session data is stored on your site.

 

I'd like to take a closer look to be sure. Could you send me the experiment ID of this test? I will create a support ticket for you to troubleshoot further.

 

 

Best,

David
Technical Support Representative
Optimizely - EMEA

 

Optimizely