Rich-text Reply

X-frame-options not allowing page loading in editor

doubleH 11-26-14

X-frame-options not allowing page loading in editor

At the moment we are unable to load our site in the editor because we have http header x-frame-options set to deny and thereby preventing loading of the site into an iframe.

One solution mentioned was to use a Chrome extension that allows the site to load. Does anyone know how or where to get the extension? Or any other solution?

Level 1

Amanda 11-26-14
 

Re: X-frame-options not allowing page loading in editor

Great question. X-frame security settings are a very common issue. 

 

Best case scenario would be to adjust your HTTP Header to allow a specific domain to iFrame your site. In this case, you want to allow optimizely.com . Your tech team should easily be able to take care of doing this. Here's a MSDN Blog article which clearly explains the issue and solution: http://blogs.msdn.com/b/ieinternals/archive/2010/03/30/combating-clickjacking-with-x-frame-options.a...

 

 

However, a quick Google search returned this extension & it sounds like what you are looking for: https://chrome.google.com/webstore/detail/ignore-x-frame-headers/gleekbfjekiniecknbkamfmkohkpodhe?hl...

 

I have not tried this extension myself, so I'm unsure if it works. Do you want to give it a go and let us know if it does the trick? We'd all love to hear about it if so! 

 

 

Optimizely
KenBrown 01-15-15
 

Re: X-frame-options not allowing page loading in editor

Amanda,

Thank you for this Chrome extension. It appears to work. Before I would get the X-frame errors and continue to get the Reload button. Now I am able to get into my experiment through the editor. Thank you.
Level 2