Rich-text Reply

google analytics custom dimensions not running ?

MiGHTyDuCK 10-26-15

google analytics custom dimensions not running ?

Hi

 

I implanted Optimizley code in the head and implanted Google anlaytics using custom HTML with GTM and added whats needed for optimilzey integration.

 

I created a CD in GA interface and enabled the integration in the expirement.

Even now I see the the CD is not excecuting correctly

 

Executing Google Analytics commands.
Running command: ga("t0.set", "dimension3", "Optimizely_Homepage (3530531762): Variation_1")

and it doesnt appear in the google analytics debugger

 

any suggestions ?

 

Thanks in advance !

 

 

robertchan 10-26-15
 

Re: google analytics custom dimensions not running ?

Hi,

I've been in the process of setting the same thing up - for one, you might not be seeing any data in GA yet because it takes 24 hours to propagate. If you have multiple experiments running at the same time on a page, you'll need to create separate CDs so that data from one experiment doesn't interfere with another. One last thing you might want to check is that within whatever experiment you're pushing data out of, GA has been turned on in the Integration section. Make sure your custom tracker is set appropriately (e.g. in my case, I've set it to universal for UA).
Robert Chan

Experimentation Hero
MiGHTyDuCK 10-27-15
 

Re: google analytics custom dimensions not running ?

Hi Robert,

Thank you for taking the time to reply.

 

Not seeing data in GA I can understand (still not seeing by the way) but in GA debugger I dont see the custom dimension as a part of the pageview hit.

This is not the first test i am doing it and it usually works like a charm, I dont know why but with test its not showing up correctly.

I turend on the integrations and in the exiprement editor chose the correct CD number.

I tried using a custom tracker as t0, you think I should try and put my UA there ?

I'll give it a shot.

This is the only expirement I am doing on this page.

 

Thank you for helping !

 

robertchan 10-27-15
 

Re: google analytics custom dimensions not running ?

Anytime! It sounds like the custom tracker is not matching what has been implemented in your snippet, but in any case, yes, I'd try putting your UA there. Another issue might be with GA itself - as mentioned, propagation could take up to 24 hours unless you're using GA premium.
Robert Chan

Experimentation Hero

Re: google analytics custom dimensions not running ?

Hi,

Here is my experience (I was not using GTM, but it might still be of some help), I followed all the steps you did but did not put the Custom Dimension Code that Google Analytics provided when creating the slot, instead used the following code and placed it between ga('create'....) and ga('send','pageview'):

 

// Optimizely Universal Analytics Integration
window.optimizely = window.optimizely || [];
window.optimizely.push("activateUniversalAnalytics");

 

https://help.optimizely.com/hc/en-us/articles/200039995

 

Also make sure you went to the experiment Editor > Options > Integrations > and then added the created slot number > Save.

Hope this helps.

pl804 07-08-16
 

Re: google analytics custom dimensions not running ?

I'm having the same issue.  Worked before, now isn't on a new experiment.

 

Can someone remind me if the experiment needs to be running to see cd[x] in GA Debugger - or will it show up if I use the force parameter while the expt is still paused?

Level 1